Recherche
 
Fermer
A ne pas manquer !
GuppY-Education
GuppY-Aide
Recherche
Recherche
Webmaster - Infos
Visites

 1297213 visiteurs

 18 visiteurs en ligne

Lettre d'information
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
AknnW
Recopier le code :
19 Abonnés
Préférences

Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe


Connectés :
( personne )
Snif !!!

13 Janvier 2013

A lire avant de patcher !
Nous vous proposons le patch spécial guppy école 4.6.22 avec des corrections et des nouveautés dont :

  • l'ajout d'un pseudo-groupe privé auquel sont ajoutés automatiquement tous les membres.
  • Ajout de la version 3.6.5 de CKEditor
  • Suppression de l'ancien éditeur : FCK editor :

vous devez supprimer les répertoires
admin/editors/fckeditor_config et inc/fckeditor,
les fichiers admin/editors/editorFCK.php et admin/editors/postdataFCK.php.

 

Nouveautés pour les skins :

  • Suppression de la skin island : vous devez supprimer dans le répertoire skin de GuppY,  le répertoire skin_island.
  • Ajout de 2 skins :
  • la skin Guppy01 en skin d'origine
  • la skin crayon cire blanc

ATTENTION : la skin Valric-ecole n'est plus compatible avec la version 4.6.22 de Guppy !


vous devez supprimer dans le répertoire skin de GuppY,  le répertoire valric_ecole

 


Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT

ce correctif pour la sécurité de votre site.
 



Si vous avez un Guppy Ecole 4.6.21a

 

deux méthodes au choix :

  1. Méthode simple et rapide : le patch de mise à jour spécial GuppyEcole 4.6.22.
  2. Méthode traditionnelle.

 

ATTENTION ! il est conseillé de faire une sauvegarde de votre site avant application d'un patch de mise à jour.


  • 1. Méthode simple et rapide : Appliquez le patch complet de mise à jour GuppyEcole 4.6.22 !  Téléchargeable ici.

Guppyed vous a proposé le pack GuppyEcole  "clé en main", alors, pour le mettre à jour, notre équipe met à disposition des utilisateurs un patch sécurité complet :

  "patch_mise_a_jour_guppy_ecole_v4.6.22" qui permet de mettre votre guppy ecole à jour d'un seul coup et qui contient les mises à jour suivantes :

-Guppy V4.6.22

-quizz 3

-admin-redac 5.5.9.1

-le plugin jmForks 4.6.22 : Ce plugin permet de gérer l'ensemble des forks, ceux qui sont nécessaires au bon fonctionnement des plugins de Jean Mi, en particulier : Ajoute Menu http://www.jmmis.com/

 

A noter pour les utilisateurs qui sont hébergés chez FREE !

Le plugin Ajoute-menu nécessite PHP 5.2.3, or les sites hébergés chez Free en PHP5, sont sous PHP 5.1.3. Reportez-vous sur le site de Jean Mi le créateur du plugin Ajoute-menu pour y trouver des informations : http://www.jmmis.com/

 

Cas de plugin jmForks :

dans ce dernier patch, il n'y a pas de mise à jour de Ajoute menu, puisque la version n'a pas changé depuis novembre 2012, cependant comme à chaque sortie de patch guppy, le développeur du plugin (Jean Mi :
http://www.jmmis.com/) met à disposition un plugin-fork, nommé plugin jmForks 4.6.22. Pour l'installer, rendez-vous dans la partie de l'admin des plugins, cliquez sur le plugin "jmForks 4.6.22", puis dans la partie "Tous les forks", cliquez sur installer.


NOTE :
Les autres plugins du pack GuppyEcole d'origine - ,open fiches et ajoute menu 4.6.25
ont la même version.

N'oubliez pas de mettre à jour aussi les plugins que vous avez vous-même installés en plus dans votre GuppyEcole !

 

Cas de la skin Valric_ecole incompatible avec 4.6.22 :

Si vous utilisiez la skin Valric_ecole sur votre site, celle-ci n'est plus compatible avec la version 4.6.22 de Guppy, il ne faut plus l'utiliser

Pour compenser ce désagrément, nous avons mis dans ce pack, une skin "crayon_cire blanc".

Pour l'installer : allez dans admin, config thèmes et choisissez : crayon cire blanc. Puis enregistrez la config. Cette skin, n'utilise pas un thème d'icones.
 

  • 2. Méthode traditionnelle :
- appliquez le patch guppy sécurité NON CUMULATIF 4.6.22 : téléchargeable ici.
-Mettre également à jour les plugins contenus dans le pack et ceux que vous avez éventuellement installés ainsi que le fork ajoute menu :
-admin-redac 5.5.9.1
-plugin jmForks 4.6.22 téléchargeable sur : www.jmmis.com/      lien direct

Vérifiez également la version de vos autres plugins et s'il existe une mise à jour.

 
 
 
____________________________________________________________________

Si vous avez un Guppy Ecole inférieur à 4.6.21a

-Vous devez appliquer le patch sécurité CUMULATIF 4.6.22 : téléchargeable ici.
-Mettre également à jour tous les plugins contenus dans le pack et ceux que vous avez éventuellement installés ainsi que le plugin jmForks
 

NOTE : Pour connaître la version de vos plugins et savoir s'il existe une dernière version, les développeurs ont prévu l'affichage de cette info sur la page d'administration du plugin.
RDV en admin, allez dans la partie inférieure de la page : administration des plugins. Cliquez sur l'icone de chaque plugin, le n°de version est indiqué, dans certains cas, il faut cliquer sur une icone "Vérifier version" ou "version", on vous indique alors l'existence d'une nouvelle version, il n'y a plus qu'à cliquer sur le lien pour accéder à son téléchargement sur le site de l'auteur.

Comment patcher ?
 

  1. Tout ce que vous avez à faire c’est de remplacer les fichiers existants sur votre serveur par ceux contenus dans le patch. Vous n’avez pas besoin d’envoyer le répertoire install. Profitez de l’occasion pour vérifier qu’il ne fait pas partie des répertoires de votre site. Si c’est le cas, supprimez-le pour des raisons de sécurité.
  2. Vérifiez la version de Guppy en vous connectant sur votre site et en vous rendant dans l’Admin. Cliquez sur « A propos ». Vous devez voir écrit 4.6.22. Votre patch est alors correctement appliqué.
  3. Rendez-vous dans Admin Config boîte et Config accueil pour valider tous les paramètres que vous aviez choisis avant de patcher afin d’éviter des messages d’erreur.  

doc.gifDocumentation :

Disponible : tutoriel " Comment patcher ? ICI
Guide technique php 4 vers php 5  ICI

 

 

Attention ! Si vous avez un Guppy 4.5.xx c'est à dire inférieur à la version 4.6,  vous ne devez pas patcher votre site mais vous devez effectuer une migration vers la dernière version de Guppy 4.6.22 !

Pour cela vous devez télécharger la toute dernière version de Guppy : ici.

La procédure n'est pas la même !

Pour savoir comment effectuer une migration : cliquez ici.

Lavachequireve - GuppyTeam

 

 


Date de création : 06/01/2013 @ 20:22
Dernière modification : 18/01/2013 @ 00:49
Catégorie : -
Page lue 2921 fois

Vous êtes ici :   Accueil » Patch et version de sécurité 4.6.22

 Hébergement Nuxit notre partenaire

Ce site respecte la charte de l'anneau Sitinstit