Recherche
 
Fermer
A ne pas manquer !
GuppY-Education
GuppY-Aide
Recherche
Recherche
Webmaster - Infos
Visites

 1364852 visiteurs

 38 visiteurs en ligne

Lettre d'information
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
2GpeWB
Recopier le code :
19 Abonnés
Préférences

Se reconnecter :
Votre nom (ou pseudo) :
Votre mot de passe


Connectés :
( personne )
Snif !!!

15 octobre 2013

A lire jusqu'au bout avant de patcher !
Nous vous proposons le patch spécial guppy école 4.6.28

Correction de failles de sécurité, amélioration ...
 

Nouveautés pour les skins (rappel):

  • Suppression des skins island, skin_1, skin_css : vous devez supprimer dans le répertoire skin de GuppY,  les répertoires skin_island et skin_1 et skin_css
  • Ajout de 2 skins :
  • la skin Guppy01 en skin d'origine
  • la skin crayon cire blanc

ATTENTION : la skin Valric-ecole n'est plus compatible depuis la version 4.6.22 de Guppy !

vous devez supprimer dans le répertoire skin de GuppY,  le répertoire valric_ecole


Vous devez installer IMPERATIVEMENT et IMMEDIATEMENT

ce correctif pour la sécurité de votre site.

Ce patch est à appliquer sur un Guppy Ecole 4.6.26 ou inférieur (4.6.xx)

Comment appliquer le patch ?

Deux méthodes au choix :

  1. Méthode simple et rapide : le patch de mise à jour spécial GuppyEcole 4.6.28
  2. Méthode traditionnelle.

 

ATTENTION ! il est conseillé de faire une sauvegarde de votre site avant application d'un patch de mise à jour.

 

Note SECURITE ANTI-SPAM :
Les robots spammeurs exécutent des requêtes sur les noms de fichiers standards qui se trouvent dans les scripts open source des CMS tels que GUPPY, ce qui engendre une surcharge importante du trafic en hébergement mutualisé. Certains  sites sont ainsi suspendus par les hébergeurs.

 - Le renommage des fichiers postguest.php, user.php et newsletter.php par un nom personnalisé pour chaque site est, à notre avis, impératif.
 - Le renommage de guestbk.php aussi vu le nombre de requêtes visant le livre d'or, même si cela a un impact sur le référencement du livre d'or.
 - Le renommage de blogs.php, blog.php, forum.php, fortopic.php, thread.php, news.php peut être à l'appréciation du webmestre ou en fonction des requêtes sur le site car l'impact sur le référencement est beaucoup plus important.

De sorte que, avec ces fichiers ainsi renommés par le webmestre, les robots spammeurs se "casseront le nez" !
Le renommage de fichiers se passe dans la section Admin>>Config Services. Lire le tuto correspondant contenu dans le zip dans le dossier documentation (tuto_configurer_ANTI-SPAM.pdf)

 

 

 

 

  • 1. Méthode simple et rapide : Appliquez le patch complet de mise à jour GuppyEcole 4.6.28 !  Téléchargeable ici.

Guppyed vous a proposé le pack GuppyEcole  "clé en main", alors, pour le mettre à jour, notre équipe met à disposition des utilisateurs un patch sécurité complet :

  "patch_mise_a_jour_guppy_ecole_v4.6.28" qui permet de mettre votre guppy ecole à jour d'un seul coup et qui contient les mises à jour suivantes :

-Guppy V4.6.28

-le plugin Openfiches 6.29

-le plugin Ajoute-menu 4.6.27

-le plugin jmForks 4.6.28 : Ce plugin permet de gérer l'ensemble des forks, ceux qui sont nécessaires au bon fonctionnement des plugins de Jean Mi, en particulier : Ajoute Menu http://www.jmmis.com/

 

A noter pour les utilisateurs qui sont hébergés chez FREE !

Le plugin Ajoute-menu nécessite PHP 5.2.3, or les sites hébergés chez Free en PHP5, sont sous PHP 5.1.3. Reportez-vous sur le site de Jean Mi le créateur du plugin Ajoute-menu pour y trouver des informations : http://www.jmmis.com/

 

Cas de plugin jmForks :

Comme à chaque sortie de patch guppy, le développeur du plugin (Jean Mi) :
http://www.jmmis.com/) met à disposition un plugin-fork, nommé plugin jmForks 4.6.28_131012. Pour l'installer, rendez-vous dans la partie de l'admin des plugins, cliquez sur le plugin "jmForks 4.6.28", puis dans la partie "Tous les forks", cliquez sur installer.


NOTE :
Les autres plugins du pack GuppyEcole d'origine - ,Admin Redac et Quiz gardent les mêmes versions et n'ont pas besoin d'être mis à jour avec ce patch.

N'oubliez pas de mettre à jour aussi les plugins que vous avez vous-même installés en plus dans votre GuppyEcole !

 

Cas de la skin Valric_ecole incompatible avec 4.6.28 :

Si vous utilisiez la skin Valric_ecole sur votre site, celle-ci n'est plus compatible depuis la version 4.6.22 de Guppy, il ne faut plus l'utiliser

Pour compenser ce désagrément, nous avons mis depuis dans le pack Guppy Ecole, une skin "crayon_cire blanc".

Pour l'installer : allez dans admin, config thèmes et choisissez : crayon cire blanc. Puis enregistrez la config. Cette skin, n'utilise pas un thème d'icones.
 

 

  • 2. Méthode traditionnelle pour le GuppyEcole 4.6.5 ou inférieur:
- appliquez le patch guppy sécurité  CUMULATIF 4.6.28 : téléchargeable ici.
-Mettre également à jour les plugins contenus dans le pack et ceux que vous avez éventuellement installés :
-Open Fiches 6.29 téléchargeable sur http://www.randosnormandie.info    lien direct
-Ajoute Menu 4.6.27 téléchargeable sur : www.jmmis.com/     lien direct
-plugin jmForks 4.6.28 téléchargeable sur : www.jmmis.com/      lien direct

Vérifiez également la version de vos autres plugins et s'il existe une mise à jour.
 
 
 
APRES application du patch :
Ne pas oublier de revalider les pages de config surtout Config Accueil et Config boîtes
 
 
 
Comment patcher ?
  1. Tout ce que vous avez à faire c’est de remplacer les fichiers existants sur votre serveur par ceux contenus dans le patch. Vous n’avez pas besoin d’envoyer le répertoire install. Profitez de l’occasion pour vérifier qu’il ne fait pas partie des répertoires de votre site. Si c’est le cas, supprimez-le pour des raisons de sécurité.
  2. Vérifiez la version de Guppy en vous connectant sur votre site et en vous rendant dans l’Admin. Cliquez sur « A propos ». Vous devez voir écrit 4.6.28. Votre patch est alors correctement appliqué.
  3. Rendez-vous dans Admin Config boîte et Config accueil pour valider tous les paramètres que vous aviez choisis avant de patcher afin d’éviter des messages d’erreur.  

doc.gifDocumentation :

Disponible : tutoriel " Comment patcher ? ICI
Guide technique php 4 vers php 5  ICI

 

 

Attention ! Si vous avez un Guppy 4.5.xx c'est à dire inférieur à la version 4.6,  vous ne devez pas patcher votre site mais vous devez effectuer une migration vers la dernière version de Guppy 4.6.22 !

Pour cela vous devez télécharger la toute dernière version de Guppy : ici.

La procédure n'est pas la même !

Pour savoir comment effectuer une migration : cliquez ici.

Fred & Lavachequireve - GuppyTeam

 

 


Date de création : 13/10/2013 @ 15:31
Dernière modification : 15/10/2013 @ 23:02
Catégorie : -
Page lue 3935 fois

Vous êtes ici :   Accueil » Patch et version de sécurité 4.6.28

 Hébergement Nuxit notre partenaire

Ce site respecte la charte de l'anneau Sitinstit